FreeConference.com service interruption
Incident Report for FreeConference
Resolved
Service is now fully restored as of 12/07/2021 at 21:26 p.m UTC.
Posted Dec 07, 2021 - 21:28 UTC
Investigating
The web conferencing service is currently experiencing a higher than normal amount of load, and may be causing pages to be slow or unresponsive. We're investigating the cause and will provide an update as soon as possible.

Note that your telephone conferencing services have NOT been impacted in any way.
Posted Dec 07, 2021 - 20:58 UTC
This incident affected: Join Calls by Internet, Online Meeting Room, Video Conferencing, Account Logins, New Account Signups, and Mobile (iOS / Android) Apps.