FreeConference.com Service Disruption
Incident Report for FreeConference
Resolved
This incident has been resolved as of 11:44 EST
Posted Dec 10, 2020 - 16:58 UTC
Identified
We are currently experiencing a disruption to video conferencing and screensharing.

The issue has been identified and our team is diligently working on a resolution.
Posted Dec 10, 2020 - 16:35 UTC
This incident affected: Join Calls by Internet, Join Calls by Phone, Online Meeting Room, Video Conferencing, and Screen Sharing.