FreeConference.com Service Disruption
Incident Report for FreeConference
Resolved
This incident has been resolved.
Posted Nov 09, 2020 - 21:58 UTC
Identified
We are currently experiencing a disruption to our conferencing services.

Our team is diligently working to resolve this issue.

We will follow up with an email as soon as the service has been restored.
Posted Nov 09, 2020 - 21:13 UTC
This incident affected: Join Calls by Internet and Join Calls by Phone.