North American Telecommunications Congestion
Incident Report for FreeConference
Resolved
This incident has been resolved.
Posted Apr 16, 2020 - 13:24 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 09, 2020 - 00:46 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 19, 2020 - 13:43 UTC
Monitoring
Some customers have reached out after experiencing issues when joining a conference call via telephone. Please note that our phone bridges and related network have the capacity to handle the increased call volume and that any issues are related to capacity on the North American telecom network at large.

The vast majority of phone calls are successfully connecting, and we strongly recommend continuing to dial back in if you experience issues getting through. You may use these additional dial-in numbers to connect to the same call and using the same access code:

717-275-8940
605-562-0400
425-436-6260
641-426-1600
712-832-8330
605-475-4120

Most connectivity issues are solved by calling into any of these alternate numbers.

Given the circumstances, and to further increase the success of your calls, here are some tips to help ensure important calls are successful:

- Schedule calls at non-peak times (ie. 11:20am versus 11:00am)
- Schedule calls earlier in the morning (ie. 8am)
- Schedule calls later in the day (ie. 4pm onward)
- Connect to calls via your web browser. VoIP audio is not affected by telecom capacity and will always work, and you have the option to deactivate your video. With a free subscription, you can have up to 5 people connect via the internet. With a paid plan, up to 100 can join this way.

Additionally, we are in constant communication with the main carriers in Canada/US who are responsible for core telecommunications infrastructure. We are doing everything we can to keep you connected.
Posted Mar 19, 2020 - 13:39 UTC
This incident affected: Join Calls by Phone.