FreeConference.com Service Disruption
Incident Report for FreeConference
Resolved
Full services are now restored. This issue was resolved as of 9:50 AM ET (13:50 UTC), 24th October.
Posted Oct 24, 2020 - 14:02 UTC
Update
We are continuing to work on a fix for this issue.
Posted Oct 24, 2020 - 12:58 UTC
Identified
We are currently experiencing a disruption to our conferencing services.

Our team is diligently working to resolve this issue.

We will follow up with an email as soon as the service has been restored.
Posted Oct 24, 2020 - 12:57 UTC
This incident affected: Join Calls by Internet and Join Calls by Phone.