FreeConference.com partial phone service interruption
Incident Report for FreeConference
Resolved
This incident has been resolved.
Posted Sep 09, 2021 - 16:04 UTC
Identified
We are currently experiencing technical difficulties with the 712 area code

We are diligently working to resolve this issue with our provider

In the meantime, please use any of the following dial-in numbers with the same access code:

605-562-0400 and 605-475-4120
Posted Sep 09, 2021 - 15:35 UTC
This incident affected: Join Calls by Phone.