FreeConference.com service interruption
Incident Report for FreeConference
Resolved
This incident has been resolved.
Posted Aug 10, 2020 - 16:25 UTC
Identified
We are currently experiencing technical difficulties with the dial-in number: 605 475 2875

We are diligently working to resolve this issue.

In the meantime, please use any of the following dial-in numbers with the same access code:

605 562 0400
717 275 8940
712 832 8330
Posted Aug 05, 2020 - 22:58 UTC
This incident affected: Join Calls by Phone.