FreeConference.com Service Disruption
Incident Report for FreeConference
Resolved
This incident has been resolved.
Posted Jul 21, 2020 - 19:44 UTC
Update
We are continuing to investigate this issue.
Posted Jul 21, 2020 - 19:15 UTC
Investigating
The web conferencing service is currently experiencing an issue with video. Both the site and app are affected, audio is unaffected, but no video is being displayed.

Note that your telephone conferencing services have NOT been impacted in any way.
Posted Jul 21, 2020 - 19:12 UTC
This incident affected: Video Conferencing.