FreeConference Service Update
Incident Report for FreeConference
Resolved
This incident has been resolved.
Posted Aug 22, 2023 - 22:59 UTC
Identified
The web conferencing service is currently experiencing a higher-than-normal amount of load and may be causing pages to be slow or unresponsive. We're investigating the cause and will provide an update as soon as possible.

Note that your telephone conferencing services have NOT been impacted in any way.
Posted Aug 22, 2023 - 21:18 UTC
This incident affected: Join Calls by Internet, Online Meeting Room, and Video Conferencing.