Difficulties logging in to FreeConference.com
Incident Report for FreeConference
Resolved
This incident has been resolved.
Posted Aug 02, 2021 - 15:55 UTC
Identified
Some users may be experiencing trouble when logging in to their FreeConference account. Our team is currently investigating this issue Updates to follow. In the meantime, please use https://hello.freeconference.com/login. For Legacy accounts use https://legacy.freeconference.com/home.aspx
Posted Aug 02, 2021 - 15:34 UTC
This incident affected: Account Logins.