FreeConference.com service interruption
Incident Report for FreeConference
Resolved
This incident has been resolved.
Posted Jul 16, 2020 - 01:23 UTC
Investigating
We are currently investigating this issue.
Posted Jul 16, 2020 - 01:03 UTC
Identified
We are currently experiencing technical difficulties with some dial in numbers

We are diligently working to resolve this issue.

In the meantime, please join conferences online or try the alternate dial in 717-275-8940
Posted Jul 16, 2020 - 00:55 UTC
This incident affected: Join Calls by Phone.